1. 시작하기에 앞서

1.1 이게 뭐죠?

  이 소프트웨어는 Windows 8/8.1/10의 화면 각 부분의 글꼴을 설정하는 도구입니다.
  어째선지 Windows 8/8.1/10에서 표준 화면의 각 부분의 글꼴을 설정할 수 없게 되었기에 이 프로그램을 만들었습니다.

1.2 작동 환경

  본 프로그램은 Windows 8, 8.1 그리고 10에서 작동합니다.
  데스크탑에 표시된 윈도우의 각 부분의 글꼴을 설정하기 때문에 데스크탑 응용프로그램입니다.

  Windows 2000부터 7까지도 동작은 합니다만, 저 운영체제들은 화면 각 부분의 글꼴을 자체적으로 설정할 수 있기 때문에 의미가 없습니다.

1.3 파일들

파일 이름 | 설명
noMeiryoUI.exe | 메인 프로그램 파일입니다.
Korean.lng | 한국어 현지화 파일입니다.
Chinese (Simplified)_China.lng | 중국어(간체) 현지화 파일입니다.
English.lng | 영어 현지화 파일입니다.
default.lng | 기본 현지화 파일(영어)입니다.
Korean.chm | 한국어 도움말 파일입니다.
Japanese.chm | 일본어 도움말 파일입니다.
Chinese (Simplified)_China.chm | 중국어(간체) 도움말 파일입니다.
English.chm | 영어 도움말 파일입니다.
default.chm | 기본 도움말 파일(영어)입니다.
src.zip | 본 프로그램의 소스코드 압축파일 입니다. 보통은 사용하지 않습니다만, 이 소프트웨어의 동작을 조사하고 싶은 경우 혹은 프로그램을 개량하고 싶은 경우 사용합니다. (역자: 최신 버전은 github에 공개되어 있습니다.)

1.4 설치

설치

모든 파일을 같은 폴더 아래에 압축 해제합니다.

삭제

모든 파일을 삭제하세요.


2. 사용 방법

2.1 소개

  탐색기에서 noMeiryoUI.exe의 아이콘( [image])을 더블클릭하는 등, noMeiryoUI.exe를 실행합니다.
  아래 화면이 표시됩니다.
  Windows의 버전은 제품명(내부 버전 번호) 형식으로 표시하고 있습니다. 동작 확인, 오류 보고 등에 사용해주세요.

No!! Meiryo UI 화면

2.2 조작 방법

  화면이 표시되면 화면 각 부분의 명칭과 설정되어 있는 글꼴 이름이 표시됩니다.
  글꼴을 변경하려면 글꼴 이름 옆에 있는 [선택...] 버튼을 누르세요.

  글꼴 선택 대화상자가 표시되면 글꼴, 글꼴 크기, 서식을 취향에 따라 설정해주세요.
  모든 글꼴 설정을 끝내 [확인] 버튼을 누르면, 선택한 글꼴이 화면의 각 부분에 설정됩니다.

  "@"로 시작하는 이름의 세로쓰기용 글꼴은 글꼴 선택 대화상자에서 표시되지 않으며, 따라서 선택할 수 없습니다.

2.3 글꼴 [모두 설정]

  맨 위에 표시되는 [모든 글꼴]이라는 항목은 화면의 각 부분의 글꼴을 모두 같은 글꼴, 글꼴 크기, 서식으로 설정하는 항목입니다.
  글꼴 이름 옆의 [선택...] 버튼을 눌러 글꼴 선택 대화상자에서 글꼴을 선택한 후 [모두 설정] 버튼을 누르면 화면의 각 부분의 글꼴이 모두 같은 글꼴, 글꼴 크기, 서식으로 설정됩니다.

  "@"로 시작하는 이름의 세로쓰기용 글꼴은 글꼴 선택 대화상자에서 표시되지 않으며, 따라서 선택할 수 없습니다.

2.4 글꼴 선택

  글꼴 이름 옆에 있는 [선택...] 버튼을 누르면 아래와 같은 글꼴 선택 대화상자가 표시됩니다.
글꼴 선택 대화상자

  글꼴 선택 대화상자에서는 다음과 같은 값을 설정할 수 있습니다.

명칭 | 기능
글꼴 이름(F) | 글꼴을 지정합니다.
스타일(Y) | 글꼴의 스타일(굵게, 기울임꼴 등)을 지정합니다.
크기(S) | 글꼴 크기를 지정합니다.
밑줄(U) | 체크하면 밑줄이 적용됩니다.
취소선(T) | 체크하면 취소선이 적용됩니다.
문자 집합(C) | 문자 집합을 선택합니다.

  글꼴을 선택하고 [확인] 버튼을 누르면 글꼴이 선택됩니다.
  선택 필수 부분이 선택되지 않은 경우 오류 메시지가 표시되므로 지시에 따라 필수 부분을 선택해주세요.

2.5 메뉴

  • 파일(F)
    • 글꼴 설정 열기(O)...
      파일 열기 대화상자가 표시되면 [글꼴 설정 저장(A)...]를 통해 저장한 ini 파일을 선택해주세요.
      파일을 선택하면 [모든 글꼴]을 제외한 [제목 표시줄]부터 [메뉴]까지의 항목의 글꼴 설정이 ini 파일의 설정으로 지정됩니다.
    • 글꼴 설정 저장(A)...
      선택한 글꼴 설정을 ini 파일에 저장합니다.
      저장되는 설정은 [모든 글꼴]을 제외한 [제목 표시줄]부터 [메뉴]까지의 항목의 글꼴 설정입니다.
      파일 저장 대화상자가 표시되면, 확인하기 쉽게 파일 이름에 글꼴 이름을 붙여 저장해주세요.
    • 시스템 글꼴 설정 및 종료(S)
      선택한 글꼴을 화면 각 부분에 설정하고 프로그램을 종료합니다.
    • 종료(X)
      글꼴 설정을 적용하지 않고 프로그램을 종료합니다.
  • 프리셋(P)
    • Windows 8/8.1
      [모든 글꼴] 이외의 설정을 Windows 8/8.1의 기본값으로 되돌립니다.
    • Windows 10
      [모든 글꼴] 이외의 설정을 Windows 10의 기본값으로 되돌립니다.
  • 도구(T)
    • 개별 스레드에서 시스템 글꼴 설정(A)
      특정 상황 하의 트러블슈팅 용 설정을 수행합니다.
      SetPoint(Logicool 마우스/키보드 유틸리티) 등을 실행한 환경에서 글꼴을 설정했을 때 '응답 없음'이 되는 경우, 이 메뉴를 체크하고 글꼴을 설정해주세요.
      이 메뉴는 기본적으로 체크되어 있습니다.
    • Windows 7 방식의 글꼴 크기 계산(7)
      글꼴 크기의 계산을 Windows 7과 같은 방식으로 합니다.
      Windows 8/8.1에서 Windows 7 이전과 동일한 글꼴 크기를 지정하고 싶을 경우 이 옵션을 사용합니다.

      이 옵션을 체크 해제한 상태에서 글꼴 크기에 11포인트 이상을 지정한 경우, 글꼴 크기는 Windows 8/8.1의 디스플레이 설정의 텍스트 크기와 같은 크기가 됩니다. 이 경우, 글꼴 크기에 따라 Windows 7 이전의 텍스트 크기 값보다 1픽셀 커집니다.
      이 옵션을 체크한 후 글꼴을 설정하면 Windows 8/8.1이라도 글꼴의 크기가 Windows 7 이전과 같은 크기가 됩니다.
      이 옵션을 사용하여 글꼴 크기를 지정하는 것은 이 옵션을 설정한 후에 선택한 글꼴 설정에만 유효합니다.
      Windows 7 이전의 OS와 Windows 10에서 이 옵션은 비활성화되고, 선택 불가능하게 됩니다. 글꼴 크기 계산은 Windows 7 이전 OS에 준합니다.
  • 도움말(H)
    • 도움말(H)
      이 문서를 열어 화면에 표시합니다.
    • No!! Meiryo UI에 대하여(A)...
      본 프로그램의 버전 대화상자을 표시합니다.

2.6 명령줄 옵션

  명령줄 옵션으로 실행 시에 글꼴 설정을 읽을 수 있고, 지정한 글꼴 설정을 자동으로 시스템 글꼴로 설정하는 것이 가능합니다.

  명령줄은 다음과 같은 형식을 따릅니다.
noMeiryoUI 글꼴 설정 파일 이름 [-set]

  글꼴 설정 파일은 이 프로그램에서 글꼴 설정을 저장한 ini 파일을 의미합니다.
  글꼴 설정 파일 이름에 공백이 있을 경우 파일 이름을 "(쌍따옴표)를 이용해 묶어주세요.

  글꼴 설정 파일 이름 뒤에 공백을 넣고 -set라고 입력하면 지정한 글꼴 설정 파일의 내용으로 시스템 글꼴을 설정하고 프로그램을 종료합니다.
배치 파일 등에 사용하면 미리 준비한 글꼴 설정 파일의 내용으로 시스템 글꼴을 한번에 설정하는 것이 가능해 편리합니다.

예1. MySet.ini라는 글꼴 설정 파일을 실행 시 읽는 경우

  MySet.ini라는 글꼴 설정 파일을 실행 시에 읽는 경우 명령줄 등에 다음과 같이 입력합니다.
noMeiryoUI MySet.ini

예2. Your Settings.ini라는 글꼴 설정 파일의 내용으로 시스템 글꼴을 설정하는 경우

  Your Settings.ini라는 글꼴 설정 파일에 따라 시스템 글꼴을 설정하는 경우 명령줄 등에 다음과 같이 입력합니다.
noMeiryoUI "Your Settings.ini" -set


3. 제작 이력

2018/04/28 Version 2.35

  • 표시 언어만 변경하고 시스템 로캘은 변경하지 않은 경우, 표시 언어로 보이도록 했습니다.
  • 글꼴 크기를 키웠습니다.
  • deVbug님의 협력으로 한국어 번역을 추가했습니다.
  • 한국어 글꼴이름을 올바르게 보이게 했습니다. (한국어인 경우만 적용)

2017/06/03 Version 2.34

  • 실행할 때 프로그램을 마우스 포인터가 있는 모니터의 중앙보다 약간 왼쪽 위에 표시하도록 했습니다.
  • 글꼴 선택 대화상자를 프로그램 메인 창의 중앙에 표시하도록 했습니다.
  • 도움말 파일을 프로그램 메인 화면이 표시되어있는 모니터의 중앙보다 약간 왼쪽 위에 표시하도록 했습니다.
  • 중국어(간체)판 도움말의 글꼴이 일부 다른 글꼴로 표시되는 문제를 수정했습니다.

2017/05/14 Version 2.33

  • Windows 10에서 실행했을 때 상세한 버전 정보를 표시하도록 했습니다.
  • 영문판 Windows에서도 프리셋 메뉴가 기능하도록 했습니다.
  • 각 언어로의 번역에 대비해, 표시 글꼴과 프리셋의 문자 집합을 변경할 수 있도록 했습니다.
  • 읽어들일 언어 파일, 도움말 파일 이름을 Windows의 로캘 정보로부터 결정하도록 했습니다. 따라서 번역을 추가할 때 프로그램을 변경할 필요가 없고, 언어 파일만 배포하면 되게 되었습니다.

2016/10/10 Version 2.32

  • 타치바나 겍카님의 도움으로 도움말의 중국어(간체) 버전을 포함하고, 중국어(간체)판 Windows에서 실행할 때 표시할 수 있도록 했습니다.
  • 중국어(간체)판 Windows에서도 프리셋 메뉴가 기능하도록 했습니다.
  • 각 언어로의 번역에 대비해, 소스코드 폴더 구조를 변경하고 메시지를 기술한 파일과 도움말 파일의 번역 방법에 대해 간단한 설명을 추가했습니다.

2016/09/19 Version 2.31

  • 타치바나 겍카님이 중국어(간체)로 번역해주셨습니다. 이제 중국어(간체)판 Windows에서 중국어(간체)로 표시됩니다.
  • 도움말의 국제화에 대비해, 도움말을 HTML로 변경했습니다.
  • 버전 정보에 번역자의 정보를 추가했습니다.
  • 일본어판 이외의 Windows에서 버전 정보를 표시했을 때 발생하는 잠재적 문제를 수정했습니다.

2016/08/19 Version 2.30

  • 일본어 이외의 OS를 위한 다국어 지원이 추가되었습니다. 이 버전에선 일본어, 중국어(간체), 그 외 언어로 메시지가 변경됩니다.
    단, 저는 중국어를 모르기에 이 버전에선 임시로 중국어(간체)판 Windows에서 실행할 때 영어로 표시됩니다.

2016/06/09 Version 2.20

  • 명령줄로부터 설정 파일을 지정할 수 있도록 했습니다. 또한, 명령줄로부터 지정한 설정 파일의 내용에 글꼴을 설정할 수 있도록 했습니다.

2016/02/23 Version 2.17

  • 선택한 글꼴의 글꼴 이름과 크기를 선택한 글꼴로 표시하도록 했습니다.
    글꼴 이름만 보면 Meiryo UI가 멀쩡한 글꼴로 보이는게 난감하지만요.

2015/08/16 Version 2.16

  • [다른 스레드에서 글꼴 변경]을 기본적으로 활성화하도록 수정했습니다.
  • Windows 10용 프리셋을 추가했습니다.
  • 시스템 DPI에 대해 대응했습니다.

2015/07/20 Version 2.15

  • 글꼴 크기를 글꼴 이름과 함께 표시하도록 했습니다.
  • 글꼴 선택 대화상자를 표시할 때 지금까지 선택되어 있던 글꼴이 대화상자의 각 항목에 설정되도록 했습니다.
  • Windows 8/8.1의 기본 글꼴 설정을 화면 각 항목에 설정하는 프리셋 메뉴를 추가했습니다.
  • Windows 8/8.1에서 기본 설정의 글꼴 크기 값을 디스플레이 설정의 텍스트 크기에 맞추도록 했습니다.
    이에 따라, Windows 7 이전의 OS 및 글꼴 선택 일반 대화상자와 같은 글꼴 크기의 표시 설정을 수행하기 위해, [Windows 7 방식의 글꼴 크기 계산] 옵션을 추가했습니다.

2015/01/04 Version 2.14

  • 글꼴 설정을 파일로 저장하는 기능을 추가했습니다.

2014/07/13 Version 2.13

  • 다른 스레드에서 글꼴 설정을 변경하는 설정을 추가하였습니다.
    SetPoint(Logicool 마우스/키보드 유틸리티) 등을 실행한 환경에서 글꼴을 설정했을 때 '응답 없음'이 되는 경우 사용해주세요.
    이 설정의 추가에 따라, 이 설정을 위한 메뉴를 추가했습니다.
  • 글꼴 설정 시 LOGFONT 구조체의 lfOutPrecision, lfClipPrecision, lfQuality 값은 글꼴 정보 획득 시에 반환된 값이 아닌, 0(디폴트)으로 설정하도록 했습니다. 이로인해, 설정한 글꼴 정보가 Windows 7까지의 화면 디자인으로 설정한 값과 맞게 되었습니다.

2013/10/06 Version 2.12

  • Windows 8.1에 대비하여 Windows의 버전을 표시하는 기능을 추가했습니다. 트러블슈팅에 사용해주세요.
  • Windows 8.1을 제대로 감지하기 위해 manifest를 추가로 기록하였습니다.

2013/02/23 Version 2.11

  • IObit StartMenu 8 실행 중에 글꼴 설정을 수행하면 프로그램이 중단되는 현상을 수정하였습니다.
  • [모두 설정]을 수행한 후, [확인]버튼을 눌렀을 때 [아이콘]에 선택한 글꼴과는 다른 글꼴이 설정되는 문제를 수정하였습니다.
  • MIT 라이센스를 소스코드에 첨부하였습니다.

2013/02/17 Version 2.10

  • 글꼴 선택 시 Application Verifier에 오류가 나는 등 글꼴 선택 전후 과정이 오류의 원인이 되었기에, 글꼴 선택 대화상자를 자체 제작한 것으로 교체하였습니다.
  • 글꼴 선택 대화상자에 세로쓰기용 글꼴이 나타나지 않도록 했습니다.
  • 글꼴 선택 대화상자에서 문자 집합에 일본어가 존재하는 글꼴을 선택한 경우, 일본어 문자 집합이 기본적으로 선택되도록 했습니다.
  • 글꼴 선택 대화상자에서 밑줄, 취소선을 선택할 수 있도록 했습니다. (사용할라나?)

  프로그램 실행 시 명령줄 옵션에 "noMeiryoUI"(쌍따옴표는 불필요하고 대소문자 주의)를 붙여서 실행하면...?

2013/02/11 Version 2.02

  선택한 글꼴의 글꼴 이름이 "@"로 시작하는 경우, 정말 의도하고 선택한 글꼴인지 확인하는 대화상자를 표시할 때 그 조건이 잘못되어 수정하였습니다.

  이상 종료에 대응하기 위해, 글꼴 선택 대화상자가 정상적으로 표시되지 않은 경우 알림 대화상자를 표시하도록 했고, 글꼴 선택 대화상자 표시 시 초기화 처리를 검토했습니다.
  다음 판에서 글꼴 선택을 공통 대화상자가 아닌 자체 제작으로 대체할 예정입니다.

2013/02/03 Version 2.01

  선택한 글꼴의 글꼴 이름이 "@"로 시작하는 경우, 정말 의도하고 선택한 글꼴인지 확인하는 대화상자를 표시하도록 했습니다.

  실수로 글꼴 이름이 "@"로 시작하는 세로쓰기용 글꼴을 선택하는 사례가 많기에 미리 확인을 할 수 있도록 했습니다.

2012/11/18 Version 2.00

  [Meiryo UI도 정말 싫어!]로 수정된 초판입니다.
  화면 각 부분의 글꼴 크기 설정 기능을 추가했습니다.

2005/09/25 Version 1.00

  본 프로그램의 전신인 [Tahoma따위 정말 싫어!]의 초판입니다.


4. 라이센스와 제작자에 대해

저작권

  이 소프트웨어는 Tatsu(庄子 達彦; 타츠히코 쇼지)가 저작권을 보유하는 프리웨어입니다.
  이 소프트웨어는 무료로, 목적을 불문하고 자유롭게 사용해도 상관없습니다.
  하지만, 전재 시 알려주시면 제작자가 기뻐합니다.

  제작자는 이 소프트웨어를 사용함에 있어 되도록 문제가 발생하지 않도록 유의하고 있습니다만, 이 소프트웨어를 사용하는 중 발생하는 그 어떤 문제에 대해서도 제작자는 일체의 책임을 지지 않습니다.

  의견, 감상 등이 있으시다면, 아래 기록한 제작자의 연락처로 연락주시기 바랍니다.

소스 파일은 MIT 라이센스(http://opensource.org/licenses/mit-license.php)를 따릅니다.

제작자

庄子 達彦(타츠히코 쇼지; Tatsu)
E-mail Address rxk16664@nifty.ne.jp
My Web page http://tatsu.life.coocan.jp/index.html

번역자

언어 | 번역자
한국어 | deVbug
중국어(간체) | Gekka Tachibana,kingofotaku
일본어, 영어 | Tatsu