1.始めに

1.1 本ソフトは何か?

  本ソフトはWindows 8/8.1/10で画面の各部分のフォントを設定するツールです。
  なぜかWindows 8/8.1/10では標準で画面の各部分のフォントを設定することができなくなっていたので作成しました。

1.2 動作環境

  本プログラムはWindows 8/8.1/10で動作します。
  デスクトップに表示されたウインドウの各部分のフォントを設定するのでデスクトップアプリです。

  Windows 2000から7でも動作しますが、これらのOSでは画面の各部分のフォントを設定することが当たり前にできますので意味がありません。

1.3 構成ファイル

ファイル名 | 内容
noMeiryoUI.exe | 本ソフトの実行ファイルです。
Chinese (Simplified)_China.lng | 簡体字中国語で動作させるときのメッセージを記述したファイルです。
English.lng | 英語で動作させるときのメッセージを記述したファイルです。
Korean.lng | 韓国語で動作させるときのメッセージを記述したファイルです。
default.lng | 日本語、英語、簡体字中国語、韓国語以外で動作させるときのメッセージを英語で記述したファイルです。
Japanese.chm | 日本語版ヘルプファイルです。
Chinese (Simplified)_China.chm | 簡体字中国語版ヘルプファイルです。
English.chm | 英語版ヘルプファイルです。
Korean.chm | 韓国語版ヘルプファイルです。
default.chm | 日本語、英語、簡体字中国語、韓国語以外で動作させるときのヘルプファイルです。
src.zip | 本ソフトのソースファイルです。 通常は使用しませんが、本ソフトの動作を調べたい場合やプログラムを改良したい場合に使用します。

1.4 インストール・アンインストール

インストール

  インストールする際は本ソフトのアーカイブを全部同じディレクトリに展開してください。

アンインストール

  アンインストールを行う場合は本ソフトを展開したディレクトリごと消してください。


2.本ソフトの使い方

2.1 始めに

  エクスプローラーからnoMeiryoUI.exeのアイコン [image] をダブルクリックするなどして、noMeiryoUI.exeを実行してください。
  下記の画面が表示されます。
  Windowsのバージョンは製品名(内部バージョン番号)という形式で表示しております。動作確認、障害報告等にご利用ください。

2.2 操作方法

  画面が表示されると画面の各部分の名称と設定されているフォント名が表示されます。
  フォントを変更する際はフォント名の横にある選択ボタンを押下してください。

  フォント選択ダイアログが表示されるので、フォント・フォントサイズ・書式を好みに合わせて設定してください。
  設定が終わったらOKボタンを押下すると選択したフォントが画面の各部分に設定されます。

  選択したフォントの中にフォント名が"@"で始まるフォントが存在する場合は選択したフォントが本当に意図したものかどうかの問い合わせダイアログが表示されます。
  問い合わせダイアログが表示された場合は「いいえ」を押すとフォントの選択を行いません。「はい」を押すとフォントが設定されます。

2.3 フォントの一括設定

  一番上に表示されている「すべてのフォント」という項目は画面の各部分のフォントを同じフォント・フォントサイズ・書式で設定するための項目です。
  フォント名の横の選択ボタンを押下して、フォント選択ダイアログからフォントを選択した後、一括設定ボタンを押下すると画面の各部分のフォントが同じフォント・フォントサイズ・書式で設定されます。

  選択したフォントのフォント名が"@"で始まる場合は選択したフォントが本当に意図したものかどうかの問い合わせダイアログが表示されます。
  問い合わせダイアログが表示された場合は「いいえ」を押すとフォントの選択を行いません。「はい」を押すとフォントが設定されます。

2.4 フォントの選択

  フォント名の横にある選択ボタンを押下すると下記のフォント選択ダイアログが表示されます。
フォント選択ダイアログ

  フォント選択ダイアログでは以下の指定を行うことができます。

名称 | 機能
フォント名(F) | フォントを指定します。
スタイル(Y) | フォントのスタイル(太字/斜体)を指定します。
サイズ(S) | フォントサイズを指定します。
下線(U) | チェックすると下線を付けます。
取り消し線(T) | チェックすると取り消し線をつけます。

  フォントを選択してOKボタンを押下するとフォントを選択します。
  選択必須の箇所が選択されてない場合、エラーメッセージが表示されますので指示に従って選択を行ってください。

2.5 メニュー操作

  • ファイル(F)
    • フォント設定を読み込む(O)...
      選択したフォントを画面の各部分に設定してプログラムを終了します。 ファイル選択ダイアログが表示されるのでメニュー項目「フォント設定を保存する(A)...」で保存したiniファイルを選択してください。
      ファイルを選択するとタイトルバーからメニュー/選択項目のフォントの設定にiniファイルの設定が設定されます。
    • フォント設定を保存する(A)...
      選択したフォントの設定をiniファイルに保存します。
      保存する設定はタイトルバーからメニュー/選択項目のフォントの設定です。
      ファイル保存ダイアログが表示されるので、ファイル名を付けて保存してください。
    • フォントを設定して終了(S)
      選択したフォントを画面の各部分に設定してプログラムを終了します。
    • 終了(X)
      フォントを設定せずにプログラムを終了します。
  • プリセット(P)
    • Windows 8/8.1
      すべてのフォント以外の設定をWindows 8/8.1の初期状態に戻します。
    • Windows 10
      すべてのフォント以外の設定をWindows 10の初期状態に戻します。
  • ツール(T)
    • 別スレッドでフォントを変更する(A)
      環境依存のトラブルシューティング用の設定を行います。
      SetPoint(Logicoolのマウス・キーボードユーティリティ)等を起動した環境でフォントを設定した時に応答なしになる場合、本メニューをチェックしてからフォントの設定を行ってください。
    • フォントサイズをWindows 7と同様に扱う(7)
      フォントサイズの扱いをWindows 7と同じにします。
      Windows 8/8.1でWindows 7以前と同じのフォントサイズを指定したい場合に本オプションを使用します。

      本オプションのチェックを外した状態でフォントサイズに11ポイント以上を指定した場合、フォントサイズはWindows 8/8.1のディスプレイコントロールパネルのテキストサイズと同じ大きさになります。この場合、フォントサイズによってはWindows 7以前のテキストサイズの指定より1ピクセル大きくなります。
      本オプションをチェックした後、フォントを設定するとWindows 8/8.1でもフォントの大きさがWindows 7以前と同じ大きさになります。
      本オプションによるフォントの大きさの指定は本オプションを設定した後にフォントを選択したフォント設定にのみ有効になります。
      Windows 7以前のOSとWindows 10では本オプションはグレーアウトして、選択不可能になります。フォントサイズの計算はWindows 7以前のOSに準じます。
  • ヘルプ(H)
    • ヘルプの表示(C)
      このドキュメントを表示します。
    • バージョン情報(A)...
      本プログラムのバージョンを表示します。

2.6 コマンドラインオプション

  コマンドラインからオプションを指定することで起動時にフォント設定を読み込むことができるほか、指定したフォント設定で自動的にシステムフォントを設定することができます。

  コマンドラインの書式は以下の通りです。
noMeiryoUI フォント設定ファイル名 [-set]

  フォント設定ファイルには本プログラムでフォント設定を保存したiniファイルを指定します。
  フォント設定ファイル名に空白を含む場合はファイル名を"(ダブルクォーテーション)で囲ってください。

  フォント設定ファイル名の後に空白を入れて-setと入力すると指定したフォント設定ファイルの内容でシステムフォントを設定してプログラムを終了します。
バッチファイルなどで使用するとあらかじめ用意したフォント設定ファイルの内容にシステムフォントを一発で設定することができて便利です。

例1. MySet.iniというフォント設定ファイルを起動時に読み込む場合

  MySet.iniというフォント設定ファイルを起動時に読み込む場合はコマンドプロンプトなどから以下のように入力します。
noMeiryoUI MySet.ini

例2. Your Settings.iniというフォント設定ファイルの内容にシステムフォントを設定する場合

  Your Settings.iniというフォント設定ファイルにシステムフォントを設定する場合はコマンドプロンプトなどから以下のように入力します。
noMeiryoUI "Your Settings.ini" -set


3.製作履歴

2018/04/28 Version 2.35

  • 表示言語だけ変更して、システムロケールを変更しない場合に表示言語で表示されるようにしました。
  • 様々な方向けにフォントサイズを大きくしました。
  • deVbug様のご協力により、韓国語訳が追加されました。
  • 韓国語フォント名の置き換えに対応しました(韓国語の場合のみ)。
  • kingofotaku様のご協力により、簡体字中国語訳の質が向上しました。

2017/06/03 Version 2.34

  • 起動時にメイン画面をカーソルのいるモニタの中央より若干左上に表示するようにしました。
  • フォント選択ダイアログをメインウインドウの上の中央に表示するようにしました。
  • ヘルプファイルをメイン画面が表示されているモニタの中央より若干左上に表示するようにしました。
  • 簡体字中国語版ヘルプのフォントが一部異なるフォントで表示される不具合を修正しました。

2017/05/14 Version 2.33

  • Windows 10で実行した際に詳細なバージョン情報を表示するようにしました。
  • 英語版Windowsでもプリセットメニューが機能するようにしました。
  • 各言語への翻訳に備え、表示フォントとプリセットの文字セットを変更できるようにしました。
  • 読み込む言語ファイル・ヘルプファイル名をWindowsのロケール名から決めるようにしました。これにより、翻訳を追加する際にプログラムの変更が不要になる他、言語ファイルのみを配布することができるようになります。

2016/10/10 Version 2.32

  • 立花 月下様のご協力により、ヘルプの簡体字中国語版を同梱し、簡体字中国語版Windowsで実行した際に表示されるようにしました。
  • 簡体字中国語版Windowsでもプリセットメニューが機能するようにしました。
  • 各言語への翻訳に備え、ソースファイルのアーカイブのフォルダ構成を変更し、メッセージを記述したファイルとヘルプファイルの訳し方の簡単な説明を追加しました。

2016/09/19 Version 2.31

  • 立花 月下様のご協力により、メッセージが簡体字中国語へ翻訳されましたので簡体字中国語版Windowsで実行した際に表示が簡体字中国語になります。
  • ヘルプの国際化に備え、ヘルプをHTMLヘルプにしました。
  • バージョン情報に翻訳者のクレジットを追加しました。
  • 日本語版以外のWindowsで実行した際にバージョン情報を表示したときの潜在不良を修正しました。

2016/08/19 Version 2.30

  • 日本語以外のOSで実行した際にメッセージが変わるようにしました。本バージョンでは日本語、簡体字中国語、その他の言語でメッセージが変わるようにしました。
    ただし、私は中国語はわからないので本バージョンでは仮として、簡体字中国語版Windowsで実行した際も英語表示になります。

2016/06/09 Version 2.20

  • コマンドラインから指定した設定ファイルの読み込みを行えるようにしました。また、コマンドラインから指定した設定ファイルの内容にフォントを設定できるようにしました。

2016/02/23 Version 2.17

  • 選択したフォントのフォント名とサイズを選択したフォントで表示するようにしました。
    フォント名だけを見ると、Meiryo UIがまともなフォントに見えてくるのが難点ですが。

2015/08/16 Version 2.16

  • 初期設定で別スレッドでのフォント変更を行うようにしました。
  • Windows 10用のプリセットを追加しました。
  • システムDPIへの対応を行いました。

2015/07/20 Version 2.15

  • フォントサイズをフォント名とともに表示するようにしました。
  • フォント選択ダイアログを表示した際に今まで選択されていたフォントがダイアログの各項目に設定されるようにしました。
  • Windows 8/8.1の初期状態のフォントを画面の各項目に設定するプリセットメニューを追加しました。
  • Windows 8/8.1では初期状態でフォントサイズの表示・設定をディスプレイコントロールパネルのテキストサイズに合わせるようにしました。
    これに伴い、Windows 7以前のOSやフォント選択コモンダイアログと同様のフォントサイズの表示・設定を行えるよう、「フォントサイズをWindows 7と同様に扱う」オプションを追加しました。

2015/01/04 Version 2.14

  • フォント設定をファイルに保存する機能を追加しました。

2014/07/13 Version 2.13

  • 別スレッドでフォントの設定を変更する設定を追加しました。
    SetPoint(Logicoolのマウス・キーボードユーティリティ)等を起動した環境でフォントを設定した時に応答なしになる場合に使用してください。
    この設定の追加に伴い、メニューを追加しました。
  • フォント設定時にLOGFONT構造体のlfOutPrecision、lfClipPrecision、lfQualityに対してフォント情報取得時に返された値ではなく、0(デフォルト)を設定するようにしました。これにより、設定するフォント情報がWindows 7までの画面のデザインで設定する値と合うようになりました。

2013/10/06 Version 2.12

  • Windows 8.1に備えて、Windowsのバージョンを表示する機能を追加しました。トラブルシューティングにご利用ください。
  • Windows 8.1を正しく検出するため、マニフェストを追記しました。

2013/02/23 Version 2.11

  • IObit StartMenu 8を起動中にフォントの設定を行うと応答が返らない不具合を修正しました。
  • 一括設定を行った後、OKボタンを押したときにアイコンに画面上の表示と異なるフォントが設定される不具合を修正しました。
  • MITライセンスのソースコードを添付しました。

2013/02/17 Version 2.10

  • フォント選択実施時にApplication Verifierでエラーが出るなどフォント選択の前後が障害の原因になっていたため、フォント選択ダイアログを自前のものにしました。
  • フォント選択ダイアログに縦書きフォントを出さないようにしました。
  • フォント選択ダイアログで文字セットに日本語があるフォントについてはフォントを選択した際、文字セットに日本語を指定するようにしました。
  • フォント選択ダイアログで下線、取り消し線を指定できるようにしました。(使うかな？)

  起動時のコマンドラインオプションに"noMeiryoUI"(ダブルクォーテーションは不要、大文字小文字は書かれている通りに入力すること。)をつけて起動すると...？

2013/02/11 Version 2.02

  選択したフォントの中にフォント名が"@"で始まるフォントが存在する場合、選択したフォントが本当に意図したものかどうかの問い合わせダイアログを表示する条件が誤っていたので修正を行いました。

  異常終了に対応するため、フォント選択ダイアログが正常に表示されなかったときにダイアログを出すようにした他、フォント選択ダイアログ表示時の初期化処理を見直しました。
  次の版ではフォント選択を共通ダイアログではなく、自分で作成する予定です。

2013/02/03 Version 2.01

  選択したフォントの中にフォント名が"@"で始まるフォントが存在する場合、選択したフォントが本当に意図したものかどうかの問い合わせダイアログを表示するようにしました。

  意図せずにフォント名が"@"で始まる縦書き用フォントを指定する事例が多いので事前確認を行うようにしました。

2012/11/18 Version 2.00

  「Meiryo UIも大っきらい!!」としての初版です。
  画面の各部分のフォントサイズの設定機能を追加しました。

2005/09/25 Version 1.00

  本ソフトの前身となるソフトウェア、「Tahomaなんて大っきらい!」の初版です。


4.ライセンスと作者について

著作権など

  本ソフトウェアは著作権をTatsuこと庄子達彦が保有するフリーウェアです。
  本ソフトは無料で目的を問わず自由に使ってかまいません。
  が、転載する際には一声いただけると作者が喜びます。

  作者は本ソフトを利用するにあたってなるべく不具合が出ないよう心がけておりますが、本ソフトの運用結果に対して作者は一切責任を取りません。

  ご意見・ご感想などありましたら、下記の作者のところに一声いただけるとうれしいです。

ソースファイルについてはMITライセンス(http://opensource.org/licenses/mit-license.php)に従います。

作者

庄子 達彦(Tatsu)
E-mail Address rxk16664@nifty.ne.jp
My Web page http://tatsu.life.coocan.jp/index.html

翻訳者

言語 | 翻訳者
簡体字中国語 | 立花 月下様、kingofotaku様
韓国語 | devBug様
日本語、英語 | Tatsu